The emergency maintenance has been completed, all recordings are available in the user interface.
Posted Feb 06, 2026 - 06:49 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 05, 2026 - 03:45 UTC
Scheduled
We are currently performing emergency maintenance to ensure Call Recordings and Voicemails are fully available. Please be assured there is no data loss.
While we work on this over the next few days, you may notice that older recordings are temporarily unavailable from your user interface or via API requests. There is no loss of Recordings or Voicemails, we just need to take them offline briefly to get everything back in order. In the meantime, new recordings will be made available in the user interface.
We will provide daily updates on this maintenance. For further information please contact our support team.
Posted Feb 05, 2026 - 03:43 UTC
This scheduled maintenance affected: US (mytalkdesk.com) (Talkdesk Call Recording™ (Talkdesk Workforce Engagement)).