Call Flows & Routing degraded Performance
Incident Report for Talkdesk
Resolved
The incident is fully resolved. In case some remaining agents did not update the status recently and are not receiving calls when available, we recommend a session logout/login. In case you need additional support please contact our support team (https://support.talkdesk.com/hc/en-us/requests/new).
Posted Sep 20, 2021 - 18:18 UTC
Update
At this point the initial issue was fully resolved, we can see recovery on our system. Monitoring will continue.
Posted Sep 20, 2021 - 17:32 UTC
Update
After extensive testing, we can confirm the issue has been fully resolved. The impacted customers should no longer be experiencing the inbound call assignment issues. Monitoring will continue.
Posted Sep 20, 2021 - 16:59 UTC
Monitoring
We are already seeing recovery on-call delivery to agents. We will continue to monitor the situation.
Posted Sep 20, 2021 - 16:32 UTC
Update
Some delays in assigning Inbound calls to agents might still be noticed currently for a subset of customers. Some agents can also be experiencing calls getting disconnected when answered by the agents. Outbound calls are not impacted. We have increased system capacity to resolve the inbound call issue. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 16:18 UTC
Update
We were able to observe some improvements, but some delay assigning Inbound calls to agents might still be noticed currently for a subset of customers. Outbound calls are not impacted. We have increased system capacity to resolve the inbound call issue. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 15:55 UTC
Update
The issue impacts some inbound call routing where calls are not assigned to some agents for a subset of customers. Outbound calls are not impacted. We have identified the issue and are working on recovering and restoring it. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 15:33 UTC
Update
We are continuing to work on a fix for this issue. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 15:19 UTC
Identified
The issue has been identified. Mitigation steps are in progress. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 15:01 UTC
Investigating
We are observing degraded performance on Assignment and Dial since 14:46 UTC. We will provide an update as soon as we have more details.
Posted Sep 20, 2021 - 14:51 UTC
This incident affected: Apps (Studio).