Service Degradation
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 15:26 UTC
Monitoring
Mitigation measures are in place. We advise the impacted users to refresh the App in order to work successfully. We will keep monitoring.
Posted Nov 08, 2022 - 15:23 UTC
Investigating
We are currently investigating degraded performance across Workspace and Conversation App. Mitigation Measures are in progress. We will provide an update in 15 minutes or sooner.
Posted Nov 08, 2022 - 15:07 UTC
This incident affected: Reporting & Analytics (Live Reporting), Apps (Agent Workspace), and Agent Experience & Routing (Call Controls, Call Flows & Routing).