Inbound and Outbound Call degraded performance for Brazilian numbers

Incident Report for Talkdesk

Resolved

The incident is now resolved.
Posted May 17, 2025 - 03:13 UTC

Monitoring

We have completed mitigation measures alongside our carrier. We are seeing improvements on our end and will continue to monitor. We will provide an update as soon as we have full recovery.
Posted May 17, 2025 - 03:03 UTC

Update

We are still working with our carrier to resolve this issue. Mitigation measures are still in progress. We expect to have recovery soon. We will update as soon as we are able to.
Posted May 17, 2025 - 01:54 UTC

Update

We are still working with our carrier to resolve this issue. Mitigation measures are still in progress. We expect to have recovery soon. We will update as soon as we are able to.
Posted May 16, 2025 - 23:39 UTC

Update

We are still working with our carrier to resolve this issue. Mitigation measures are still in progress. We expect to have recovery soon. We will update you within the hour.
Posted May 16, 2025 - 22:06 UTC

Update

We are still working with our carrier to resolve this issue, and we are implementing mitigation measures. We expect to have recovery soon. We will update you within the hour.
Posted May 16, 2025 - 21:01 UTC

Update

We are still working with our carrier to resolve this issue. We will update you with more details as soon as we can.
Posted May 16, 2025 - 20:43 UTC

Update

Our Carrier Partner has confirmed that a hardware issue is causing this degradation. We are working with them to resolve this issue as soon as possible. We will update you with more details as soon as we can.
Posted May 16, 2025 - 19:05 UTC

Identified

We are observing Call degradation for Inbound and Outbound calls in the LATAM region, specifically for Brazilian numbers since 17:15 UTC. US or EU numbers are not impacted. We are working with our Carrier Partner to resolve this issue on their end. We will provide an update as soon as we learn more.
Posted May 16, 2025 - 18:41 UTC
This incident affected: Americas (US) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)) and Europe (Germany) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).