EU Region calls failing
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 11:35 UTC
Monitoring
Mitigation measures are being applied by our carrier partner and at this point, we are seeing improvements in the success rate of inbound and outbound calls. We are continuously working with our partner in order to recover the service as quickly as possible. We will share more updates as soon as available.
Posted Nov 10, 2023 - 11:21 UTC
Update
Currently one of our telecommunications carriers in Europe is experiencing an incident which is causing a percentage of calls to fail. This incident does not affect customers with BYOC. We are working with our partner in order to recover the service as quickly as possible. We will share one update in 60 minutes or sooner.
Posted Nov 10, 2023 - 10:44 UTC
Update
Currently one of our telecommunications carriers in Europe is experiencing an incident which is causing a percentage of calls to fail. We are working with our partner in order to recover the service as quickly as possible. We will share an update in 30 minutes.
Posted Nov 10, 2023 - 10:19 UTC
Identified
Currently one of our carriers in Europe is experiencing an incident which is causing a percentage of calls to fail. We are working together with our partner to recover the service. We will share more updates as soon as possible.
Posted Nov 10, 2023 - 10:03 UTC
This incident affected: Europe (Germany) (Inbound (Telephony), Outbound (Telephony)).