Calls not dequeuing
Incident Report for Talkdesk
Resolved
Talkdesk’s service has been fully restored and this incident is therefore resolved.
Posted Nov 25, 2020 - 19:37 UTC
Monitoring
Talkdesk is seeing recovery. Calls should be currently dequeuing and be routed to agents. We will continue to monitor the situation and provide updates.
Posted Nov 25, 2020 - 19:15 UTC
Investigating
Talkdesk is aware of an ongoing issue caused by one of our providers resulting in calls not dequeuing to available agents mostly impacting Studio Flows. We will provide an update as soon as we have more details
Posted Nov 25, 2020 - 18:57 UTC
This incident affected: Voice (Call Flows & Routing).