Twilio Incident - Outbound and Inbound Call Failure
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 10, 2018 - 19:37 PST
Monitoring
Issue has been resolved. If you continue to experience issues, please contact us at support@talkdesk.com
Posted 7 months ago. Mar 10, 2018 - 19:27 PST
Update
Twilio has identified the cause of the issue and is working to deploy a fix immediately
Posted 7 months ago. Mar 10, 2018 - 19:02 PST
Identified
Twilio is experiencing an incident with programmable voice affecting call creation. Their engineers are engaged and actively working to restore service.
Posted 7 months ago. Mar 10, 2018 - 18:46 PST