Scheduled Maintenance

Scheduled for Sep 6, 08:00 - 12:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 01, 2026 - 14:36 UTC

Scheduled

Hello,

We will be conducting a scheduled maintenance on Talkdesk Explore as part of an effort to migrate portions of its underlying support infrastructure.

During the maintenance window you may experience the following:
- Explore may intermittently return a "Service Unavailable" message.
- Data freshness may be delayed.
- Scheduled Reports set to trigger during this window may not run as expected.

We will continue to provide updates on this maintenance schedule to keep you informed. Thank you for your patience as we carry out this work.
Posted Sep 01, 2026 - 12:30 UTC
This scheduled maintenance affects: UK (mytalkdesk.co.uk) (Talkdesk Explore™ Reporting (Talkdesk Platform)) and Canada (mytalkdeskca.com) (Talkdesk Explore™ Reporting (Talkdesk Platform)).