Inbound voice issues with US toll free numbers
Incident Report for Talkdesk
Resolved
Our Telecom Provider has confirmed that the outage is now resolved, and all services are now back to normal.
Please contact support@talkdesk.com if you have any questions.
Posted 12 months ago. Oct 04, 2016 - 09:23 PDT
Monitoring
Our Telecom Provider confirms that inbound voice traffic is being recovered, as numbers are becoming available.
We will update as soon as the issue is fully resolved.
Posted 12 months ago. Oct 04, 2016 - 08:48 PDT
Update
We have confirmed with our telecom partner a major service outage in the US. At this point of time, a large part of inbound Toll Free calls and approximately 50% of inbound calls to numbers in United States are failing. We are working towards identifying ETA of service recovery.
Posted 12 months ago. Oct 04, 2016 - 08:25 PDT
Investigating
We are investigating inbound voice issues with US toll free numbers. We will provide further information shortly.
Posted 12 months ago. Oct 04, 2016 - 07:55 PDT