Subset of calls not being delivered to agents
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 17:24 UTC
Monitoring
Mitigation measures were applied, and we are seeing improvements. We will keep monitoring the situation.
Posted Mar 22, 2022 - 17:12 UTC
Update
Mitigation measures are still in progress, a subset of inbound and outbound calls are still being affected due to a Talkdesk Telecom Provider. We will provide an update in 15 minutes or sooner.
Posted Mar 22, 2022 - 16:53 UTC
Identified
We are currently investigating a subset of calls not being delivered to agents due to a Talkdesk Telecom Partner. Incident mitigation measures are in progress and business continuity settings have been enabled where applicable. We will provide an update in 15 minutes or sooner.
Posted Mar 22, 2022 - 16:34 UTC
Investigating
We are currently investigating a subset of calls not being delivered to agents. We will provide an update in 15 minutes or sooner.
Posted Mar 22, 2022 - 16:15 UTC
This incident affected: Telephony (Inbound, Outbound).