Some users report trouble logging in
Incident Report for Talkdesk
Resolved
Agents are now reporting that they can log in to Talkdesk with no issues. Please reach out by email if you still need help.
Posted 5 months ago. Mar 02, 2018 - 12:49 PST
Update
We have made updates to our login services to help mitigate ISP issues that some users may be experiencing. Please reach out to support@talkdesk.com if you're still having trouble.
Posted 5 months ago. Mar 02, 2018 - 12:37 PST
Identified
We have received reports of agents having trouble logging in to Talkdesk and other services. There appears to be some internet issues with major ISPs and this issue does not appear to be on Talkdesk's services. Please reach out to your ISP for updates and let us know if you believe this is not the case.
Posted 5 months ago. Mar 02, 2018 - 12:31 PST