Delay assigning calls to agents
Incident Report for Talkdesk
Resolved
All systems are green since the full recovery noted in our last update. This incident is resolved.
Posted 2 months ago. Aug 12, 2019 - 14:06 PDT
Update
We've seen full recovery for assignment of Studio calls. We will continue to monitor and provide further updates if appropriate.
Posted 2 months ago. Aug 12, 2019 - 13:19 PDT
Update
We've seen recovery in assignment of Studio calls. We will continue to monitor and provide another update soon.
Posted 2 months ago. Aug 12, 2019 - 12:55 PDT
Update
We are seeing some cases where there is still a delay in routing callers to agents for a small subset of Studio calls. We’re continuing to monitor the situation.
Posted 2 months ago. Aug 12, 2019 - 12:14 PDT
Monitoring
We are seeing full recovery on Talkdesk Studio Routing and will continue monitoring.
Posted 2 months ago. Aug 12, 2019 - 10:22 PDT
Identified
Talkdesk has identified the cause of delayed dequeueing and has implemented a fix. Talkdesk studio routing is now recovering.
Posted 2 months ago. Aug 12, 2019 - 10:08 PDT
Investigating
Dequeuing calls within Studio flows apparently experiencing degraded performance where there is a delay in routing calls to agents.

Our engineering team is investigating to mitigate the issue and we will provide an update soon.
Posted 2 months ago. Aug 12, 2019 - 09:59 PDT
This incident affected: Voice - Dequeuing Calls.