Limited number of Canadian Toll-Free numbers are not working
Incident Report for Talkdesk
Resolved
Our telecom provider has confirmed that the issue is resolved.
Posted 10 months ago. Jan 12, 2018 - 12:01 PST
Update
Our Telecom provider continues to work on resolving the routing failures for inbound calls from Canada to a small subset of Twilio US Toll-free numbers.
Posted 10 months ago. Jan 12, 2018 - 09:30 PST
Update
The issue has been identified as a routing equipment failure and our telecom provider is working to fix the problem as soon as possible.
Posted 10 months ago. Jan 12, 2018 - 08:42 PST
Update
Our Telecom provider is investigating the reports of intermittent inbound voice call failures to a small subset of Twilio US and Canadian Toll-free numbers. Their engineers are working with the problematic carrier partner to determine root cause and immediate fix.
Posted 10 months ago. Jan 12, 2018 - 08:23 PST
Identified
A limited number of Talkdesk customers are experiencing issues with toll-free Canadian numbers. We have escalated to our telecommunications provider. If you are experiencing an issue, please contact us at support@talkdesk.com
Posted 10 months ago. Jan 12, 2018 - 08:07 PST