Login Inconsistency
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Feb 15, 2022 - 23:22 UTC
Update
Mitigation measures were applied, and we are continuing to see improvements. We will keep monitoring the situation and provide another update in 15 minutes.
Posted Feb 15, 2022 - 23:10 UTC
Update
Mitigation measures are still in progress and we are observing improvements. The Login inconsistencies are only affecting a subset of customers in North American regions. We will provide an update in 15 minutes or sooner.
Posted Feb 15, 2022 - 22:51 UTC
Update
Mitigation measures are still in progress. The Login inconsistencies are only affecting a subset of customers in North American regions. We will provide an update in 15 minutes or sooner.
Posted Feb 15, 2022 - 22:37 UTC
Identified
We are currently investigating login issues affecting a subset of customers in North American regions. Mitigation measures are in progress. We will provide an update in 15 minutes or sooner.
Posted Feb 15, 2022 - 22:22 UTC
This incident affected: Platform (Talkdesk ID Login) and Apps (Agent Workspace).