Problems with receiving/making calls
Incident Report for Talkdesk
Resolved
Our systems are now fully operational but we'll continue to monitor.

Please reach out to support@talkdesk.com if you encounter further issues.
Posted 12 months ago. Nov 05, 2018 - 11:19 PST
Update
We are seeing recovery across all systems. We'll continue to monitor.
Posted 12 months ago. Nov 05, 2018 - 10:13 PST
Monitoring
Our provider has identified the issue and all systems appear to be recovering.

We'll monitor the situation closely.
Posted 12 months ago. Nov 05, 2018 - 09:50 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 12 months ago. Nov 05, 2018 - 09:39 PST
Investigating
Our telecom provider is experiencing resurgent errors which have impacted our systems. The primary symptoms are dropped calls or problems making outbound calls.

We are working with them again to address the issues as quickly as possible.
Posted 12 months ago. Nov 05, 2018 - 09:39 PST
This incident affected: Voice - Incoming Browser Calls, Voice - Incoming SIP Calls, Voice - Incoming External Phone Calls, Voice - Outgoing Browser Calls, and Voice - Outgoing SIP Calls.