Issues routing calls
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Dec 18, 2020 - 23:46 UTC
Monitoring
Our platform experienced a transient issue routing calls at approximately 19:30 UTC. This is resolved. We will continue to monitor and update as appropriate.
Posted Dec 18, 2020 - 20:37 UTC
This incident affected: Agent Experience & Routing (Call Flows & Routing).