Accessing Recordings
Incident Report for Talkdesk
Resolved
We have now been able to successfully restore access to all available call recordings and voicemails.
Posted 5 months ago. Mar 03, 2017 - 10:14 PST
Update
We have successfully restored access to nearly all voicemails. Call recordings are continuing to appear progressively and we expect this job will be completed some time tomorrow. We will update this incident again once that import is complete.
Posted 5 months ago. Mar 02, 2017 - 16:12 PST
Update
Our engineers are working along with our telecom provider to restore access to yesterday's missing recordings as soon as possible. Recordings are already starting to become available progressively. We expect all recordings to be available by the end of day tomorrow. We will update this incident again either once completed or if there is a new estimate.
Posted 5 months ago. Mar 01, 2017 - 15:49 PST
Monitoring
Talkdesk is now recovering from the earlier outage. We are in the process of backfilling recordings which will take some time. We will update with more precise information when this is available.

Other parts of Talkdesk remain degraded. Please follow this other incident for updates: http://status.talkdesk.com/incidents/2mtfwzhd5m1f
Posted 5 months ago. Feb 28, 2017 - 14:47 PST
Update
The continuing outage at AWS is now affecting inbound and outbound calls.

The latest update from AWS is:

Update at 11:35 AM PST: The service updates are below. We continue to experience high error rates with S3 in US-EAST-1, which is impacting various AWS services. We are working hard at repairing S3, believe we understand root cause, and are working on implementing what we believe will remediate the issue.
Posted 5 months ago. Feb 28, 2017 - 11:40 PST
Update
Problems remain with Amazon Web Services (AWS) affecting many areas of Talkdesk including some inbound calls. We have added a new temporary phone number if you need to call us for Support: +1 855-622-5515
Posted 5 months ago. Feb 28, 2017 - 10:49 PST
Update
Due to the current incident with AWS, as well as Call Recordings, Voicemails and Greeting Messages in IVRs may also be affected.
Posted 5 months ago. Feb 28, 2017 - 10:32 PST
Identified
The issue with accessing recordings continues. This is caused by an incident with AWS. This is their latest update:

"We've identified the issue as high error rates with S3 in US-EAST-1, which is also impacting applications and services dependent on S3. We are actively working on remediating the issue."
Posted 5 months ago. Feb 28, 2017 - 10:23 PST
Investigating
We seeing errors with Recordings due to problems with a vendor. More updates soon.
Posted 5 months ago. Feb 28, 2017 - 10:09 PST