Intermittent Issues with Browser Calls
Incident Report for Talkdesk
Resolved
We haven't received any additional reports and our tests confirm that everything is back to normal again.
Posted Feb 12, 2016 - 20:51 UTC
Monitoring
Our main telecom provider experienced an issue on their end which affected the setup of some calls. The issue has since been resolved and we're monitoring the situation. Please contact us at support@talkdesk.com if you continue to be affected.
Posted Feb 12, 2016 - 20:22 UTC