Voice calls failing
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 31, 2017 - 11:50 PDT
Monitoring
We have been advised by our telecom provider that systems are now back to normal. We are continuing to monitor.
Posted 21 days ago. Aug 31, 2017 - 11:29 PDT
Investigating
We are aware of a problem right now affecting some customers answering calls. Our telecom provider is investigating. We will provide another update ASAP.
Posted 21 days ago. Aug 31, 2017 - 11:23 PDT