Desk.com slowness causing crashes
Incident Report for Talkdesk
Resolved
Desk.com have confirmed that they have implemented a solution to address the slowness on their side. Please reach out if you need more help.
Posted about 1 year ago. Oct 25, 2016 - 13:54 PDT
Monitoring
We have deployed a fix on our side to mitigate issues with Desk.com performance. If you are still affected, please reach out to support@talkdesk.com
Posted about 1 year ago. Oct 25, 2016 - 12:17 PDT
Identified
We have identified a problem affecting Desk.com CTI Widget users where desk.com crashes when attempting to pop a new case. This appears to be related to an issue currently ongoing at Desk. In the meantime we recommend Desk.com users instead use the Talkdesk Callbar, or our main application. Alternatively, you can disable case pop automations. For further assistance please reach out to us for guidance.

You can view Desk's status page here: https://status.desk.com/
Posted about 1 year ago. Oct 25, 2016 - 11:23 PDT