Accessing Talkdesk applications
Incident Report for Talkdesk
Resolved
We are able to confirm that all Talkdesk applications and services are working normally again. This includes Single Sign On (SSO), Talkdesk Live and outbound emails.

Some recordings are still unavailable as these continue to be backfilled. Please follow the progress of that here: http://status.talkdesk.com/incidents/shyy4mtvxg2d
Posted 7 months ago. Feb 28, 2017 - 16:57 PST
Update
As well as our Main web application, you can now sign in to Talkdesk via Callbar as long as you are not using SSO. Logging in with an email and password should work ok. Please switch the Main application back to "widget mode" if you had changed it earlier.

You may still see some problems with the application including missing recordings and inability to access Talkdesk Live. We are working to restore access.
Posted 7 months ago. Feb 28, 2017 - 14:56 PST
Update
Talkdesk is now recovering from the earlier outage. You can now make and receive calls from the Talkdesk Main web application. You can log in at https://account_name.mytalkdesk.com (Please replace with your own account name). You will also need to switch from "widget" to "web mode" to make and receive calls which you can do at the top of the page.

Please note that right now it's not possible to login to Callbar, or access Talkdesk Live or use SSO. We are working hard to restore all services ASAP.
Posted 7 months ago. Feb 28, 2017 - 14:35 PST
Update
We are continuing to work on mitigation but wanted to share the latest update from AWS:

12:52 PM PST: We are seeing recovery for S3 object retrievals, listing and deletions. We continue to work on recovery for adding new objects to S3 and expect to start seeing improved error rates within the hour.
Posted 7 months ago. Feb 28, 2017 - 12:59 PST
Update
The outage at AWS is ongoing. Our engineering team are actively working to mitigate the problems. In the meantime, we have a new temporary contact number for Talkdesk Support if you need to get in touch with us: (415) 729-3359
Posted 7 months ago. Feb 28, 2017 - 12:28 PST
Update
The continuing outage at AWS is now affecting inbound and outbound calls.

The latest update from AWS is:

Update at 11:35 AM PST: The service updates are below. We continue to experience high error rates with S3 in US-EAST-1, which is impacting various AWS services. We are working hard at repairing S3, believe we understand root cause, and are working on implementing what we believe will remediate the issue.
Posted 7 months ago. Feb 28, 2017 - 11:44 PST
Identified
A problem with an external vendor (AWS), is affecting access to Talkdesk applications. If you try logging in to Talkdesk you may see an error and be unable to connect. If you are currently logged in to Talkdesk, you will not be affected. Do not reload or refresh or logout, as you will be unable to get back in.

The issue is caused by an incident with AWS. This is their update:

"We've identified the issue as high error rates with S3 in US-EAST-1, which is also impacting applications and services dependent on S3. We are actively working on remediating the issue."
Posted 7 months ago. Feb 28, 2017 - 10:22 PST