Problems using Talkdesk
Incident Report for Talkdesk
Resolved
All services are working normally. If you are still having problems, please reach out to support@talkdesk.com
Posted 2 months ago. Oct 16, 2017 - 15:23 PDT
Update
We have now restored all services, including Talkdesk Live. If Talkdesk Live does not load for you, please reload Talkdesk in the browser, and wait.
Posted 2 months ago. Oct 16, 2017 - 15:11 PDT
Monitoring
We have now restored service. Please try logging in again to Talkdesk. If you don't get in immediately please wait a minute and try again. You may need to try a few times before you successfully get logged in.

For the time being Talkdesk Live will remain unavailable in order to limit the load placed on our servers.

We will update again soon when all services are back to normal.
Posted 2 months ago. Oct 16, 2017 - 14:56 PDT
Update
We are starting to see recovery on our services. It may take some time for all services to fully stabilize. We will update again soon.
Posted 2 months ago. Oct 16, 2017 - 14:48 PDT
Update
Our Engineering team continue to work on restoring service. We'll update again as soon as we hear services are back to normal.
Posted 2 months ago. Oct 16, 2017 - 14:39 PDT
Identified
Our Engineering team have identified some issues with one of our upstream Infrastructure providers and are working to mitigate the effects of that.
Posted 2 months ago. Oct 16, 2017 - 14:16 PDT
Investigating
We are aware of a problem right now affecting some customers ability to use Talkdesk. Our engineering team are investigating the root cause. We will provide another update ASAP.
Posted 2 months ago. Oct 16, 2017 - 13:57 PDT